Why the library is outputting SegmentCountNotMatching error even when SE has the proper value?

Comments

5 comments

  • Avatar
    Admin

    Hello Omar,

    Could you please raise support requests together with order id here ?

    Thank you,

    Admin

    0
    Comment actions Permalink
  • Avatar
    Omar Salas

    I have an EF Enterprise Plan with order ID, what is the way i should ask for supporting.

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Admin

    Hello Omar,

    Could you please raise support requests by clicking on the link below:

    https://support.edifabric.com/hc/en-us/requests/new

    Thank you,

    Admin

    0
    Comment actions Permalink
  • Avatar
    Rubin Xiao

    Is this resolved? I am having the same issue, can you provide the solution?

    0
    Comment actions Permalink
  • Avatar
    Admin

    Hello,

    If the message can't be parsed properly, e.g. some segments are displaces and therefore were not parsed, the resulting object will have its HasErrors set to true. This means that at least 1 segment wasn't parsed.

    When the validation runs, the segment count matching will fail, because at least one segment would be missing (the REF in the example above.).

    Technically, you don't have to run IsValid when HasErrors is true, because the message had already been flagged as invalid.

    Please go here for more info on partial parsing.

    The way to go around is to create a version of the template, where all segments follow the correct order as per the specification.

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.